'An error has occurred' while using the delist form

Minor incident Web
2020-05-20 19:05 CET · 1 week, 4 days, 22 hours, 25 minutes, 8 seconds

Updates

Resolved

We have fixed the issue.

June 1, 2020 · 17:30 CET
Investigating

Users can receive an ‘An error has occurred’ while submitting a delist request.

May 20, 2020 · 19:07 CET

← Back