DNSBL delisting currently not possible

Minor incident DNSBL
2019-11-27 01:01 CET · 8 hours, 22 minutes, 50 seconds

Updates

Resolved

Problem solved.

November 27, 2019 · 09:24 CET
Monitoring

Currently we are monitoring our server after a storage problem. Delisting is currently not possible. All requests will be processed tomorrow after 09:00 CET

November 27, 2019 · 01:04 CET

← Back